[jdom-interest] Last call: getChild/getChildren versusgetChildElement/getChildElements

Elliotte Rusty Harold elharo at metalab.unc.edu
Sun Feb 8 15:53:20 PST 2004

At 6:10 PM -0700 2/8/04, Alex Rosen wrote:

>We can't change method names from beta 9 (or really beta 1), it would
>just be wrong. It doesn't matter what we said about APIs not being
>frozen. It was incumbent upon us to not have a beta cycle that lasted 4
>years - we violated any kind of implied contract we had with our users a
>long time ago. I think that the old names are really terrible, and if we
>had fixed them a couple of months after they were created, then that
>would have been great. But fixing them 4 years later is simply
>gratuitous and shows no respect for our users.

I would expect that the incorrect method names would be deprecated 
and then removed in the following release, not eliminated 
immediately. If I recall correctly (hard to tell for sure without 
WebCVS) these methods have changed names several times before. In 
fact. I think at one point they were called something like 
getElements or getChildElements.

   Elliotte Rusty Harold
   elharo at metalab.unc.edu
   Effective XML (Addison-Wesley, 2003)

More information about the jdom-interest mailing list