[jdom-interest] Last call: getChild/getChildren versusgetChildElement/getChildElements

Alex Rosen arosen at novell.com
Sun Feb 8 23:16:14 PST 2004

"I would expect that the incorrect method names would be deprecated 
and then removed in the following release, not eliminated 

Yes, I assume that's the current plan, which is what I'm objecting to.

"If I recall correctly (hard to tell for sure without 
WebCVS) these methods have changed names several times before. In 
fact. I think at one point they were called something like 
getElements or getChildElements."

getChildren() hasn't changed, at least since beta 3. getContent() used
to be called getMixedContent(), it was changed in beta 7 (July 2001).

Alex Rosen
Novell, Inc.

More information about the jdom-interest mailing list