<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
"Peter V. Gadjokov" wrote:
<blockquote TYPE=CITE>But point taken, I'll try to make my spewage more
brief and structured. What
<br>I was suggesting was -
<p>- Move away from the 'tree-of-everything' model
<br>- Adopt a 'tree-of-elements' model
<br>- change the API to reflect this
<br> - children/parent stay and
make sense and are about Elements
<br> - content (as a collection
<br> in an element) becomes superfluous
and is removed
<br>- change the implementation to reflect this
<br> - less PartialList, more
But should addChild then stay? I quote from my posting of July 21:
<pre>I find the name getChildren misleading.
When I do an addChild(String), I would expect this to
influence the result of a call to getChildren(). It does not.
I propose to replace the name by getChildElements().
Alternatively addChild(String) could be renamed addString(String).</pre>